买股吧

 找回密码
 用户注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 168|回复: 0

如何利用涨停板选股公式

[复制链接]

436

主题

435

帖子

46

积分

版主

Rank: 7Rank: 7Rank: 7

积分
46
发表于 2019-7-17 14:17 | 显示全部楼层 |阅读模式
涨停板选股公式

{百法百中} Var7:=MA(INDEXC,62)<REF(MA(INDEXC,62),1) AND MA(INDEXC,105)<REF(MA(INDEXC,105),1) AND MA(INDEXC,62)MA(INDEXC,6)*1.11 AND MA(INDEXC,24)>MA(INDEXC,6)*1.095; Var9:=MA(INDEXC,6)>INDEXC*0.95; VarA:=H>L*1.078 AND COUNT(H>L*1.078,4)>2; 百法百中:VarA AND (C/MA(C,48)*100<67 OR C/MA(C,50)*100<69) OR Var7 AND Var8 AND Var9 AND C/COST(8)<=0.8 AND COUNT(c=o,2)=0;

{抄底高手} Var1:=(C-MA(C,48))/MA(C,48)*100<-30 AND (C-MA(C,70))/MA(C,70)*100<-27 AND COUNT((C-MA(C,48))/MA(C,48)*100<-30 AND (C-MA(C,70))/MA(C,70)*100<-27,2)=1>-0.07 and COUNT(c=o,6)=0; Var2:=(C-DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL))/DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL)*100; Var3:=REF(Var2,1)<-42>REF(Var2,1) AND REF(Var2,1)1.8; 抄底高手:(Var1 OR Var3);

{乘胜追击} Var4:=(WINNER(C)-WINNER(O))>=0.3 AND MA(V,6)/MA(V,26)>=1.9 AND V>REF(V,1) AND COUNT(SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100<20,20)>=1 AND C/MA(C,3)>=1.07; Var5:=(WINNER(C)-WINNER(O))>=0.4 AND MA(V,8)/MA(V,45)>=2.5 AND COUNT(SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100<20,20)>=1 AND C/MA(C,3)>=1.05 AND C>MA(C,85) AND V>REF(V,1); 乘胜追击:(Var4 OR Var5);

{短线黑马} Varb:=(C-DMA(C,V/MA(V,4)/4))/DMA(C,V/MA(V,4)/4)*100<-11 AND (DMA(C,V/MA(V,4)/4)-DMA(C,V/MA(V,33)/33))/DMA(C,V/MA(V,33)/33)*100<-22.3>-0.07 and COUNT(c=o,8)=0; Varc:=(C-DMA(CLOSE,VOL/MA(VOL,3)/3))/DMA(CLOSE,VOL/MA(VOL,3)/3)*100<-5; Vard:=(DMA(CLOSE,VOL/MA(VOL,3)/3)-DMA(C,V/MA(V,33)/33))/DMA(C,V/MA(V,33)/33)*100<-18; vare:="Varc">-0.05 AND COUNT(c=o,2)=0 AND SMA(SMA((INDEXC-LLV(INDEXL,250))/(HHV(INDEXH,250)-LLV(INDEXL,250))*100,30,1),50,1)<20; 短线黑马:(Varb OR Vare AND COUNT(Vare,2)=1);

{逆势买入} Varf:=(C-DMA(C,V/MA(V,4)/4))/DMA(C,V/MA(V,4)/4)*100<-8 AND (DMA(C,V/MA(V,4)/4)-DMA(C,V/MA(V,32)/32))/DMA(C,V/MA(V,32)/32)*100<-21>-0.05 and COUNT(c=o,8)=0; Var10:=SMA(SMA((INDEXC-LLV(INDEXL,275))/(HHV(INDEXH,275)-LLV(INDEXL,275))*100,50,1),40,1); Var11:=(C-MA(C,70))/MA(C,70)*100<-23 AND Var10<23 AND COUNT((C-MA(C,70))/MA(C,70)*100<-23,2)=1>C OR O0.96; 逆势买入:(Varf OR Var11);

{牛市专利} Var12:=(C-MIN(REF(C,3)*0.844,REF(C,13)*0.767))/C<0.07 AND SUM(100*V/CAPITAL,3)/3<2.345>MA(INDEXC,450) AND MA(INDEXV,61)/MA(INDEXV,80)>0.923 AND C>MA(C,190); Var13:=INDEXC>MA(INDEXC,450) AND (C-MA(C,20))/MA(C,20)*100<-16.5>0.92 AND C>MA(C,215) AND V/CAPITAL<0.075 and COUNT(c=o,5)=0; 牛市专利:(Var12 OR Var13) AND HHV(C,440)/LLV(C,440)<4;<>

{市场赢家} Var14:=H>L*1.053 AND COUNT(H>L*1.053,5)>2 AND (C/MA(C,30)*100<75 OR C/MA(C,50)*100<78); Var15:=DMA(EMA(C,5),SUM(V,8)/2.8/CAPITAL); 市场赢家:REF((C-Var15)/Var15*100,1)<-34>REF((C-Var15)/Var15*100,1) AND REF((C-Var15)/Var15*100,1)1.76 OR Var14;

{顺势搭轿} 顺势搭轿:(C-MA(C,48))/MA(C,48)*100<-28>23 AND VOL>MA(VOL,18) AND COUNT(c=o,6)=0;

{旭日东升} 旭日东升:(C-MA(C,50))/MA(C,50)*100<-23>16 AND CROSS(100*(HHV(H,27)-C)/(HHV(H,27)-LLV(L,27)),79) AND (O>C OR O<C) AND (O-REF(C,1))/REF(C,1)<0.05>MA(V,23);j1:=DYNAINFO(7); ms:=DYNAINFO(28); mx1:=DYNAINFO(34); mx2:=DYNAINFO(35); zt:ms>0 and (mx1=0 and j1=ms or mx2=0 and mx1>0 and j1=mx1);
  
{今日涨停——只要把涨停价后面加上等号就能选股} CC:=C;XX:=UBOUND(CC);C1:=CC[XX];{取最后价} GM:=STKNAME; ST:=STRLEFT(GM,2)='ST' OR STRLEFT(GM,3)='*ST'; 昨收:=REF(CC,1); N:=IF(ST,105,110); ZTJ:=ROUND(STRTONUM(NUMTOSTR(昨收*N,5))); 涨停价:ZTJ/100,LINETHICK0; 今日涨停:ROUND(C1*100)=ZTJ;

{近期涨停——只要把涨停与涨停次数后面加上等号就能选股} INPUT:P1(20,2,100); CC:=CLOSE;XX:=UBOUND(CC);C1:=CC[XX];{取最后价}C2:=CC[XX-1]; GM:=STKNAME; ST:=STRLEFT(GM,2)='ST' OR STRLEFT(GM,3)='*ST';{确定ST股} N:=IF(ST,105,110); 昨收:=REF(CC,1),LINETHICK0; ZTJ:=昨收*N; 涨停价:=ROUND(ZTJ),LINETHICK0; 今收:=CLOSE,LINETHICK0; 今日涨停:=ROUND(C1*100)=ROUND(C2*N),LINETHICK0; 涨停:ROUND(今收*100)=涨停价; 涨停次数:COUNT(涨停,IF(XX>P1,P1,0)); TJ1:=IF(今日涨停 AND 涨停次数=1,0,1); TJ2:=涨停次数>0 ,LINETHICK0; 近期涨停:TJ2 AND TJ1;

您需要登录后才可以回帖 登录 | 用户注册

本版积分规则

免责声明:买股吧官方不作任何"加入会员、承诺收益、利润分成"以及其他非法操作方式进行非法的理财服务。
买股吧论坛任何发言和广告信息仅代表本站作者或信息来源的观点,信息内容真实性、准确性和合法性,本站对此不承担任何责任。
本站部分文字及图片来自于网络,如有版权争议,请联系我们。

QQ|广告合作|网站地图|手机版|标签|小黑屋|买股吧 ( 沪ICP备16041282号-2 )

GMT+8, 2019-8-26 13:23 , Processed in 0.133938 second(s), 25 queries .

买股吧是中国专业的股票论坛,专业提供股民常用的股票公式,选股公式,股票入门,股票软件,公式源码股票资料。

快速回复 返回顶部 返回列表