请选择 进入手机版 | 继续访问电脑版

买股吧

 找回密码
 用户注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 109|回复: 0

通达信趋势浪指标主图源码

[复制链接]

564

主题

564

帖子

46

积分

版主

Rank: 7Rank: 7Rank: 7

积分
46
发表于 2019-10-8 16:31 | 显示全部楼层 |阅读模式
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));

DRAWKLINE(H,O,L,C);

EXP1:EXPMA(CLOSE,M1);

EXP2:EXPMA(CLOSE,M2);

A1:=REF(HIGH,3)=HHV(HIGH,2*3+1);

B1:=FILTER(A1,3);

C1:=BACKSET(B1,3+1);

D1:=FILTER(C1,3);{高点}

A2:=REF(LOW,3)=LLV(LOW,2*3+1);

B2:=FILTER(A2,3);

C2:=BACKSET(B2,3+1);

D2:=FILTER(C2,3);{低点}

E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;

E2:=(HIGH+LOW)/2;{高低点发现在同一K线上时可作取舍}

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

L1:=(D2 AND NOT(D1 AND E1<E2));

H2:=D1 AND NOT(D2 AND E1>=E2);

X1:=REF(BARSLAST(H1),1)+1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

G1:=F1>REF(F1,1);

I1:=BACKSET(G1,2);

LD:=I1>REF(I1,1);{过滤后低点}

L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1)+1;

F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));

G2:=F2>REF(F2,1);

I2:=BACKSET(G2,2);

HD:=I2>REF(I2,1);{过滤后高点}

DRAWLINE(LD,L,HD,H,0),COLORWHITE,LINETHICK1,DOTLINE;

DRAWLINE(HD,H,LD,L,0),COLORWHITE,LINETHICK1,DOTLINE;

J1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HD),BARSLAST(LD))+1);

J2:=J1>REF(J1,1);

DRAWLINE(J2,IF(HD,H,L),ISLASTBAR,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORWHITE,LINETHICK1,DOTLINE;

A3:=H<REF(H,REF(BARSLAST(HD),1)+1);

B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));

D3:=A3 AND B3 AND HD; E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);

HH:=E3>REF(E3,1);{找出全部长期高点}

A4:=L>REF(L,REF(BARSLAST(LD),1)+1);

B4:=REF(L,REF(BARSLAST(LD),1)+1)<REF(L,REF(BARSLAST(LD),1)+2+REF(BARSLAST(LD),REF(BARSLAST(LD),1)+2));

D4:=A4 AND B4 AND LD; E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);

LL:=E4>REF(E4,1);{找出全部长期低点}

H3:=HH OR ISLASTBAR OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点发现在同一K线}

X3:=REF(BARSLAST(H3),1)+1;

F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));

G3:=F3>REF(F3,1);

I3:=BACKSET(G3,2);

LZ:=I3>REF(I3,1),LINETHICK0; {长期低点,也可供引用}

L4:=LZ OR ISLASTBAR OR BARSCOUNT(C)=1;

X4:=REF(BARSLAST(L4),1)+1;

F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));

G4:=F4>REF(F4,1);

I4:=BACKSET(G4,2);

HZ:=I4>REF(I4,1),LINETHICK0;{长期高点,也可供引用}

DRAWLINE(HZ,H,LZ,L,0),COLORGREEN,LINETHICK1;

DRAWLINE(LZ,L,HZ,H,0),COLORGREEN,LINETHICK1;{长期连线}

K1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HZ),BARSLAST(LZ))+1);

K2:=K1>REF(K1,1);

DRAWLINE(K2,IF(HZ,H,L),ISLASTBAR,C,0),COLORGREEN,LINETHICK1; {最后地长期连线,连在收盘价上}

UU:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);

VV:=UU>REF(UU,1);

WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);

XX:=WW>REF(WW,1);

DRAWLINE(XX,L,VV,L,1),COLORMAGENTA,LINETHICK1,DOTLINE;

UU2:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);

XX2:=WW2>REF(WW2,1);

DRAWLINE(XX2,H,VV2,H,1),COLORMAGENTA,LINETHICK1,DOTLINE;

前一低:REF(L,BARSLAST(VV)),LINETHICK1,DOTLINE;

前二低:REF(L,BARSLAST(XX)),LINETHICK1,DOTLINE;

前一高:REF(H,BARSLAST(VV2)),LINETHICK1,DOTLINE;

前二高:REF(H,BARSLAST(XX2)),LINETHICK1,DOTLINE;

短高:REF(H,BARSLAST(VV2)),LINETHICK1,DOTLINE;

短低:REF(L,BARSLAST(VV)),LINETHICK1,DOTLINE;

短比:=(C-短低)/(短高-短低),LINETHICK0;

{顶分型底分型}{股票公式}

顶分形:=H<REF(H,1) AND L<REF(L,1) AND REF(H,1)>REF(H,2) AND REF(L,1)>REF(L,2);

BB1:=FILTER(顶分形,1);

CCC1:=BACKSET(BB1,2);

DD1:=FILTER(CCC1,1);{高点}

DRAWICON(DD1,H*1.009,9);

底分形:=L>REF(L,1) AND H>REF(H,1) AND REF(L,1)<REF(L,2) AND REF(H,1)<REF(H,2);

BB2:=FILTER(底分形,1);

CCC2:=BACKSET(BB2,2);

DD2:=FILTER(CCC2,1);{低点}

DRAWICON(DD2,L*0.997,8);
您需要登录后才可以回帖 登录 | 用户注册

本版积分规则

免责声明:买股吧官方不作任何"加入会员、承诺收益、利润分成"以及其他非法操作方式进行非法的理财服务。
买股吧论坛任何发言和广告信息仅代表本站作者或信息来源的观点,信息内容真实性、准确性和合法性,本站对此不承担任何责任。
本站部分文字及图片来自于网络,如有版权争议,请联系我们。

QQ|广告合作|网站地图|手机版|标签|小黑屋|买股吧 ( 沪ICP备16041282号-2 )

GMT+8, 2019-10-20 02:53 , Processed in 0.144500 second(s), 27 queries .

买股吧是中国专业的股票论坛,专业提供股民常用的股票公式,选股公式,股票入门,股票软件,公式源码股票资料。

快速回复 返回顶部 返回列表