请选择 进入手机版 | 继续访问电脑版

买股吧

 找回密码
 用户注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 349|回复: 0

波浪判断指标源码

[复制链接]

672

主题

672

帖子

46

积分

版主

Rank: 7Rank: 7Rank: 7

积分
46
发表于 2019-9-25 16:20 | 显示全部楼层 |阅读模式
N={1,800,80};M1={0.10,8};M2=(0,10,8);N2={1,30,12}
高:=REF(HHV(H,N),1);
低:=REF(LLV(L,N),1);
H1:=高-(高-低)/3;
H2:=高-(高-低)*2/3;
H3:=H2-(高-低)/6;
顶点:REFDATE(高,DATE),COLORWHITE;
第1支撑点:REFDATE(H1,DATE),COLORYELLOW;
第2支撑点:REFDATE(H2,DATE),COLORMAGENTA;
极限点:REFDATE(H3,DATE),COLORMAGENTA;
低点:REFDATE(低,DATE),COLORWHITE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,第1支撑点,'第1支撑点'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,第2支撑点,'第2支撑点'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,极限点,'极限点'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;
【箱顶】:PEAK(HIGH,10,1)*0.8*(1+M1/100),COLORGREEN;
【箱底】:PEAK(HIGH,10,1)*0.8*(1-M2/100),COLORGREEN;
【箱高】:100*(【箱顶】-(【箱顶】-【箱底】)*0.5),NODRAW;
{BIAS}{指标公式}
LC:=REF(CLOSE,1);
DRAWTEXT(CROSS((CLOSE-MA(CLOSE,N2))/MA(CLOSE,N2)*100,MA((CLOSE-MA(CLOSE,N2))/MA(CLOSE,N2)*100,N2)),LOW,'-----买入'),COLORYELLOW;
DRAWTEXT(CROSS(MA((CLOSE-MA(CLOSE,N2))/MA(CLOSE,N2)*100,N2),(CLOSE-MA(CLOSE,N2))/MA(CLOSE,N2)*100),HIGH,'-----逃顶'),COLORYELLOW;
您需要登录后才可以回帖 登录 | 用户注册

本版积分规则

免责声明:买股吧官方不作任何"加入会员、承诺收益、利润分成"以及其他非法操作方式进行非法的理财服务。
买股吧论坛任何发言和广告信息仅代表本站作者或信息来源的观点,信息内容真实性、准确性和合法性,本站对此不承担任何责任。
本站部分文字及图片来自于网络,如有版权争议,请联系我们。

QQ|广告合作|手机版|标签|小黑屋|Sitemap|网站地图|买股吧 ( 沪ICP备16041282号-2 )

GMT+8, 2019-12-14 05:07 , Processed in 0.155811 second(s), 27 queries .

买股吧是中国专业的股票论坛,专业提供股民常用的股票公式,选股公式,股票入门,股票软件,公式源码股票资料。

快速回复 返回顶部 返回列表